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Introduction
Simulation Program with Integrated Circuit Emphasis (SPICE) was originally developed at the Electronics Research Laboratory of the University of California, Berkeley in
1975 by Larry Nagel and Donald Pederson [1]. Various free and commercial versions of
SPICE simulators are among the most important tools behind the success of the whole
electronic industry. SPICE simulations help the engineers to build faster and more
powerful computers, which in turn expand the capabilities of the simulator handling
more complex circuit models. Among the commercial SPICE simulators, Star-HSPICE
[2][3] is the most widely adopted by the electrical and electronic engineers. It is touted
as “The Gold Standard for Accurate Circuit Simulation.” A SPICE simulation can
generate lots of data for a given a circuit. Depending on the complexity and accuracy
requirement, the voltage, current, and other circuit parameters can amount to a huge
number. Saving the simulation results in binary format can save signiÞcant storage (Þle
size on hard disk) compared to saving in text format. However, unlike a text Þle, the
format of a binary Þle is diﬃcult to decipher. The key for writing an HSPICE viewer
is the knowledge of the patterns and rules of those binary Þles. The maker of HSPICE,
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Synopsis, provides waveform viewers Avanwave, and Cosmos Scope. Sandwork sells a
HSPICE viewer called SPICE Explorer. The Gnu gEDA project provides a waveform
viewer, gWave on Linux and Mac platforms, which is able to read HSPICE binary Þles.
Micro Magic markets a SUE Design Manager, which contains a waveform viewer called
new spice tools (nst). Another commercial HSPICE waveform viewer called KOALA
is available from Luminis Pty. Ltd. and The University of Adelaide. A free HSPICE
waveform viewer, called HSPICE Toolbox, using Matlab can be downloaded from MIT
High Speed Circuits and Systems Group including some source codes. The HSPICE
viewer presented here is developed based the MIT code plus additional knowledge extracted from analyzing many example Þles.
Some useful URLs are listed below:
• Synopsis HSPICE:
•

http://www.synopsys.com/products/mixedsignal/hspice/hspice.html.

• Sandwork Spice Explorer:
•

http://www.sandwork.com/products spice.htm.

• gEDA gWave:
•

http://www.geda.seul.org/tools/gwave/index.html.

• Macro Magic SUE:
•

http://www.micromagic.com/tools/sue datasheet.html.
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• Luminis Pty. Ltd. and The University of Adelaide KOALA:
•

http://www.eleceng.adelaide.edu.au/Koala/.

• MIT High Speed Circuits and Systems Group:
•

http://www-mtl.mit.edu/researchgroups/perrottgroup/tools.html.

Remark 1 Since HS-View assumes the set of rules based on a trial-and-error approach,
chances are, some HSPICE files might be either incorrectly interpreted or totally unrecognizable.

0.1

Features of this tool

• Read HSPICE .tr* and .ac* Þles.
• Display list of variables saved in each Þle.
• Accommodate additional sweep parameters.
• Plot time-domain waveform with option of eye diagram generation.
• Plot frequency-domain variables Þltered by the (magnitude, phase, db, real or
imag) function.
• Export plots to vector-based graphic formats (EPS and SVG)
• Export plot data to ACSII Þles
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• HSPICE Viewer is written 100% in Java.
• The following Java numerical packages are instrumental building blocks:
— JFreechart: a comprehensive plotting package. URL: http://www.jfree.org
— PtPlot: A plotting package as a part of the Ptolemy at UC Berkeley. URL:
http://ptolemy.berkeley.edu/java/ptplot/
— Colt: a free Java toolkit at CERN for high performance computing. URL:
http://dsd.lbl.gov/˜hoschek/colt/
— JAMA (JAva MAtrix package): containss common matrix routines. URL:
http://math.nist.gov/javanumerics/jama/
— Jampack (JAva Matrix PACKage): matrix solver for complex matrices.
URL: ftp://math.nist.gov/pub/Jampack/Jampack/AboutJampack.html
1

CHAPTER 1 – MANUSCRIPT
• This document is prepared with LaTeX
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1.1

Installation

The installer is distributed as a jar Þle (say install HSV1.0.jar), which should run on
any system with support of JavaTM (at least version 1.5). In modern operating system
like Windows XP, a double click should cause the installer to be launched automatically.
If not, user may open a prompt window, change directory to the location where the
installer resides, and type
java —jar install HSV1.0.jar
The above command should also apply to any UNIX/Linux or Mac OS-X
system. After successful installation, there is a uninstall directory under the main
application directory. The jar Þle there can be used to remove the installed Þles, when
desired.
After installation, user need to add a shortcut to the desktop, which points
to the Þle named HSV.bat in the application directory. Each time, the program can be
launched through this shortcut.
Note: This application requires support of JDK1.5 or higher.
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The Main User Interface
The main graphic interface provides controls by the user through elements such as lists
and buttons inside the main GUI panel area, and the menu items.

2.1

Parts of the Main GUI Panel Area

There are four portions, as shown in Figure 2.1, inside the panel area labeled “Data
Module”, “Variables”, “Value Filter”, and “Plot Components”. Each portion consists
of a list and some buttons. Functions of these elements are described below:

2.1.1

Data Module

The upper part of this portion is a list. Each time, when a new HSPICE dataset is
read from a Þle, a new data module will be added to the list, with name derived from
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Figure 2.1: The main application window.
the original data Þle. E.g., a Þle named “D:\temp\test1.tr0” will cause a data module
“test1” to be added to the list, once the Þle is successfully loaded through the File:
Open menu.
• Button “Rename”: can be used to change the name of the data module, provided
a module in the list is selected.
• Button “Delete All”: can be used to delete all data modules.
• Button “Delete”: can be used to remove a selected data module.

2.1.2

Variables

The upper list part will display all the circuit variables from the selected data module.
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2.1.3

Value Filter

In general, the frequency-domain variables are complex-valued. Often, the real-valued
plots are preferred. The list provides the choices of Þlters (or functions) that convert
complex values to real values. The name “Real”, “Imag”, “dB”, “Magnitude” and
“Phase” are self-explanatory. On the other hand, time-domain results are all realvalued, hence the (no change) Þlter should be selected.

• Button “Add to plot”: is used to add a selected (Data Module):(Parameter):(Value
Filter) sequence to the next plot being prepared.

2.1.4

Plot Components

This part provides the necessary controls of composing a new plot.

• Button “Delete”: is used to delete the selected sequence.
• Button “Delete All”: is used to remove all sequences in the current list.
• Button “Plot All”: causes a new plot to be generated. Once a new plot is generated, it is beyond the control of the main GUI window. Please consult the section
on the “The Plotter Modules” for further information.

Once a plot is created, there are further manupulations available. Currently,
a plot can be generated with either JFreeChart or PtPlot package. More details about
plot manipulations are given in the next chapter.
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Plotting Utilities

3.1

Plotting Utility based on JFreeChart

In the standard JFreeChart distribution, there are certain built-in features for plot
manipulations. Among the choices of several plotting packages, mainly the XY data
plotting package is used in EE Circle tools. Enhancements are made to address the need
of various types of waveform display. Special eﬀorts are made, based on the JFreeChart
API, to produce publication quality graphic Þles.

3.1.1

Features Come with JFreeChart

With a right mouse click on any part of the plot, a pop-up menu will be displayed
(Figure 3.1). It contains the following menu items:
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Figure 3.1: Upon a right mouse click anywhere on the plot, a pop-up menu appears.
• Properties: allows the user to conÞgure many aspects of the plot properties.
• Save As: allows the current plot to be saved in PNG format.
• Print: allows the current plot to be sent to the printer.
• Zoom In: allows zooming into either or both axes.
• Zoom Out: allows zooming out of either or both axes.
• Auto Range: automatically sets the plotting ranges.
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Figure 3.2: The “Title” tab associated with the “Properties” pop-up menu item.
Pop-up Menu “Properties”

Once the “Properties” menu is selected, a dialog will be displayed. The dialog contains
three tabbed panes: (1) Title, (2) Plot, and (3) Other.

The “Title” Pane As shown in Figure 3.2, this allows the user to change the title
of the plot, including its font style and color.
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Figure 3.3: The “Plot” tab associated with the “Properties” pop-up menu item.
The “Plot” Pane As shown in Figure 3.3, this pane gives controls to the
labels of the X (domain) axis and the Y (range) axis. Also, user can change the bounds
of the two axes.
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Figure 3.4: The “Other” tab associated with the “Properties” pop-up menu item.
The “Other” Pane The “Other” pane, as shown in Figure 3.4 gives
additional controls over the plot attributes like background color, series and stroke
colors.
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Figure 3.5: The “Print” pop-up menu item.
Pop-up Menu “Print”
The plot can be rendered to a printer with this dialog as shown in Figure 3.5.
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Figure 3.6: The “Zoom in” pop-up memu item.

Figure 3.7: The “Zoom out” pop-up memu item.
Pop-up Menu “Zoom In”

As shown in Figure 3.6, the plot can be zoomed in either X/Y or both axes.

Pop-up Menu “Zoom Out”
As shown in Figure 3.7, the plot can be zoomed out in either X/Y or both axes.
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Figure 3.8: The “Auto Range” pop-up memu item.
Pop-up Menu “Auto Range”
Either the X or the Y axis, or both axes can be automatically adjusted to Þt all data
points.
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Figure 3.9: A typical plot window.

3.1.2

GUI Features added by EE Circle

Additional GUI elements implemented are organized by regular menus. As shown in
Figure 3.9, there are four menus on the menu bar: (1) File, (2) Plot Control, (3) Eye
Mode, and (4) Window.
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Figure 3.10: The “File” menu of a plot.
The “File” Menu

As shown in Figure 3.10, the “File” menu have the following items:

• New: the current plot will be cleared. All data will be reset.
• Delimiter: allows the user to set/change the delimiter (token separator) used
for reading/writing text data Þles.
• Scaling: allow user to deÞne a scaling factor for X or Y data. For instance, if
X-factor is set to 1e6, a sequence of x-values like {2.0e6, 3.0e6, 4.0e6, 5.0e6} will
be converted into {2.0, 3.0, 4.0, 5.0} after imported from a Þle.
• Import X Y Data: Any text data Þle in form of (X Y) or (X Y1 Y2 ...) can
be imported.
• Save Plot as: generate scalable or raster graphics Þles.
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Figure 3.11: The “Delimiter” item under the “File” menu of a plot.
• Export XY Data: save the data within the current plot into text Þle.
• Close: close the plot window.
The “Delimiter” Menu Item As shown in Figure 3.11, this allows the user to
conveniently choose a delimiter (column separator) for use with a text data Þle.

The “Scaling” Menu Item As shown in Figure 3.12, user is given the opportunity
of setting the scaling factors for X/Y data. Once ‘X Factor’ or ‘Y Factor’ is chosen, a
pop-up dialog will be displayed to receive a new scaling factor value.
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Figure 3.12: The “Scaling” item under the “File” menu of a plot.
The “Save Plot as” Menu Item As shown in Figure 3.13, there are three possible

graphic Þle formats supported:

• SVG: scalar vector graphics format. This is the most accurate representation of
the plot.
• PNG: portable network graphics format. This is a bit-mapped image format
that employs lossless data compression.
• JPG: This is the most popular raster format of graphics.
Remark 2 For user in need of the publication quality plots, it is highly recommended
to install an open source tool called Inkscape (http://www.inkscape.org/). Inkscape can
edit SVG file and export EPS file.
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Figure 3.13: The “Save Plot as” item under the “File” menu of a plot.
The “Plot Control” Menu
As shown in Figure 3.14, there are the following menu items:

• X-Grid: The radio button toggled on/oﬀ to turn on the grid lines for X axis.
• Y-Grid: The radio button toggled on/oﬀ to turn on the grid lines for X axis.
• Log-X: The radio button toggled on/oﬀ to turn on the logrithmic axis for X.
• Log-Y: The radio button toggled on/oﬀ to turn on the logrithmic axis for Y.
• X NumFormat: deÞnes a number format for X-axis labels.
• Y NumFormat: deÞnes a number format for Y-axis labels.
• X Bounds: sets the minimum, maximum and increment for X-axis.
• Y Bounds: sets the minimum, maximum and increment for Y-axis.
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Figure 3.14: The “Plot Control” menu of a plot.
• Show Legend: legend can be turned on/oﬀ.
• Legend Position: legend placed at Right, Bottom, Left or Top of the plot.
• Curves: Þner controls of the attributes of the curves.
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Figure 3.15: The pop-up dialog triggered by the “X NumFormat” item in the “Plot
Control” menu.
X/Y Number Format When either “X NumFormat” or “Y NumFormat” is se-

lected, a dialog similar to Figure 3.15 will be displayed.
A DecimalFormat pattern contains a positive and negative subpattern, for
example, ”#,##0.00;(#,##0.00)”. Each subpattern has a preÞx, numeric part, and
suﬃx. The negative subpattern is optional; if absent, then the positive subpattern
preÞxed with the localized minus sign (code>’-’ in most locales) is used as the negative
subpattern. That is, ”0.00” alone is equivalent to ”0.00;-0.00”. If there is an explicit
negative subpattern, it serves only to specify the negative preÞx and suﬃx; the number
of digits, minimal digits, and other characteristics are all the same as the positive
pattern. That means that ”#,##0.0#;(#)” produces precisely the same behavior as
”#,##0.0#;(#,##0.0#)”.
The preÞxes, suﬃxes, and various symbols used for inÞnity, digits, thousands
separators, decimal separators, etc. may be set to arbitrary values, and they will appear
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properly during formatting. However, care must be taken that the symbols and strings
do not conßict, or parsing will be unreliable. For example, either the positive and
negative preÞxes or the suﬃxes must be distinct for DecimalFormat.parse() to be able
to distinguish positive from negative values. (If they are identical, then DecimalFormat
will behave as if no negative subpattern was speciÞed.) Another example is that the
decimal separator and thousands separator should be distinct characters, or parsing
will be impossible.
The grouping separator is commonly used for thousands, but in some countries it separates ten-thousands. The grouping size is a constant number of digits
between the grouping characters, such as 3 for 100,000,000 or 4 for 1,0000,0000. If
you supply a pattern with multiple grouping characters, the interval between the last
one and the end of the integer is the one that is used. So ”#,##,###,####” ==
”######,####” == ”##,####,####”.
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Figure 3.16: Pop-up dialog for “X Bounds” item in the “Plot Control” menu.
X/Y Bounds A dialog like shown in Figure 3.16 will prompt the user with customized values to Þne tune the plot display.
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Figure 3.17: The radio button choices triggered by the “Legend Position” item in the
“Plot Control” menu.
Legend Position As shown in Figure 3.17, switching the position of the legend can

be achieved with one simple click.
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Figure 3.18: Pop-up dialog for the “Curves” item in the “Plot Control” menu.
Curves As shown in Figure 3.18, attributes of each curve (color, line property, and

symbol) can be individually adjusted through this dialog. A plot may contain multiple
curves, indexed starting 0. Only the curve of the selected index will have its attributes
updated.
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Figure 3.19: The “Eye Mode” menu.
The “Eye Mode” Menu
In modern digital applications, the quality of signal transmission from the driver to
the receiver is often characterized by an eye diagram. The menu “Eye Mode” provides
some basic facilities of converting a regular signal waveform into an eye diagram. The
following items are under this menu:

• DeÞne UI: will display a dialog, as shown in Figure 3.20, for user to enter a
value for the unit interval (UI) or bit-time.
• Oﬀset: will display a dialog, as shown in Figure 3.21, for user to enter a horizontal
oﬀset for shifting the eye pattern.
• Y ref : will promt for a reference (re-centering) Y value, as shown in Figure 3.22.
• Generate Eye: trigger the generation of an eye diagram.
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Figure 3.20: Pop-up dialog for the “DeÞne UI” item in the “Eye Mode” menu.

Figure 3.21: Pop-up dialog for the “Oﬀset” item in the “Eye Mode” menu.

Figure 3.22: Pop-up dialog for the “Y ref” item in the “Eye Mode” menu.
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An example waveform and its corresponding eye diagram is displayed in Figure 3.23 and 3.24, respectively.

Figure 3.23: An example waveform which may be folded into an eye diagram.

28

CHAPTER 3 – MANUSCRIPT

Figure 3.24: The eye diagram view of the waveform data.

The “Window” Menu
The “Window” menu provide the user a means of switching between the regular waveform and eye diagram views.

Figure 3.25: The “Window” menu in a plot.
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3.2

Plotting Utility based on PtPlot

Figure 3.26: A plot window based on the PtPlot package.

In the upper part of the plotter panel, there are three buttons:

• Original: will resume the plot to its original view.
• ConÞgure: allow user to conÞgure various properties of the plot, such as the
title, axis titles, ranges of X and Y axes.
• Zoom Fit: will automatically calculate the ranges and capture all data points.
The PtPlot plotter has several menu items under the File menu:
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Figure 3.27: The “File” menu of a PtPlot plot.
• Import X Y Data: allows the user to import additional text Þle (organized in
two columns separated by white space) and overlay with the current plot.
• Save EPS: generates an encapsulated PostScript Þle.
• Save PNG: generates a Þle in the Portable Network Graphics format.
• Export Text: exports the data points of the current plot to several two-column
X|Y data Þle in pure text format. User can transfer such data into other application for further processing or plotting.
• Close: will close the current plot window.
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4.1

Example 1: eyeTest.tr0

Selecting variables wav1 and wav2 results in 4.1. In the pop-up plot window, use
pull-down menus under “Eye Mode” by selecting UI=1.25e-9 and oﬀset=0.45. Choose
“Generate Eye” results in Figure 4.2.
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Figure 4.1: Waveforms from Example 1.

Figure 4.2: Eye diagram display of Example 1.
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4.2

Example 2: FilterA.ac0

Choose variables 1, 2, and 3 use “dB” Þlter:

Figure 4.3: Example 2: three variables as a result of an AC simulation are plotted.
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4.3

Example 3: Monte.tr0

Choose variable power and select traces associated with all the sweep variable points.
The overlapped traces are plotted below:

Figure 4.4: Example 3: Variable ‘power’ from a Monte Carlo simulation with one sweep
parameter.
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4.4

Example 4: CorrDiﬀZ.tr0

Choose zdiﬀ results in the following plot

Figure 4.5: Example 4: A plot of simulated diﬀerential impedance.
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